[MVLUG] Dell and ATI OH NOE!

syrrus at epop3.com syrrus at epop3.com
Tue May 29 11:20:01 MDT 2007


> I know that Shaun has this laptop and had problems getting the video
card to
> work.  I found some information that may help him I'd like to hear his
> thoughts.
> http://www.thinkwiki.org/wiki/ATI_Mobility_Radeon_X1400
> if you wanna test those x settings out, if the proprietary driver does
> work, then maybe it's not such a bad idea after all.

This is what I had to do to get my card to work with ubuntu:

1. You CANNOT use ubuntu's LiveCD installer - you must use the alternate
installer based on text mode debian installer.

2. The install completes and the machine reboots, but X will not
initialize with the open source driver.  apt-get install fglrx-driver (you
may need to enable the multiverse repository - can't remember)

3. Unfortunately, a dpkg-reconfigure xserver-xorg won't autodetect
anything, even if you have discover1 and xresprobe installed.  However,
you can manually make some adjustments here, such as loading fglrx as the
display driver.  Alternatively, edit the xorg.conf file directly.

4. You *should* now be able to boot.  Everything runs decently well on my
notebook.

5. Compiz / Beryl have to be run through Xgl, as the ATI proprietary
driver has no AIGLX support yet.  There are two ways to do this, either
loading Xgl as your session manager (I don't really recommend it - GTK+
themes disappeared on my machine), or hacking it into place as your
x-server with a real X session driving it in the background.  I'll have to
re-reference how I did the latter.

--Shaun @ MDC
syrrus at epop3.com




More information about the MVLUG mailing list